Join the Community
and take part in the story

Starting up docker image


Hi there,

I am newcomer here hope this is not a dummy question:)

I have followed instructions to startup a Opeio/sds image in order to use S3 compliant interface.

However docker image does not starts in my system.
I have tried several similar versions of:

docker run -ti --tty openio/sds

Always with the same result:

# Firstboot: Setting up the OpenIO cluster
# Initializing the OpenIO cluster
> Starting services
> Waiting for the services to start ...
HTTPConnectionPool(host='', port=6006): Max retries exceeded with url: /v3.0/OPENIO/conscience/list?type=meta1 (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x3834d90>: Failed to establish a new connection: [Errno 111] ECONNREFUSED',))
Error: Install script did not found 1 meta1 services registered. Return: 0

I will appreciate any hint on what is happening … am I missing something?



Hey @blacar,

There is no dummy question, we always welcome feedbacks, so thanks for that! :slight_smile:

The problem you are currently facing is related to this issue:
We will keep you posted on this thread when it will be fixed.

Anyway, if you really can’t wait to play with OpenIO, you can still use the previous version of our docker image this way:

  1. docker pull openio/sds:16.10
  2. docker run -d openio/sds:16.10
  3. docker exec -ti --tty $(docker ps -l --format "{{.ID}}") /bin/bash
  4. Enjoy!

Hope this helps!




Now I can start playing :slight_smile:

I ve run as:

docker run -ti --tty -p openio/sds:16.10

And It seems to behave good with simple operations like

aws --endpoint-url --no-verify-ssl s3 cp /etc/localtime s3://bucket1
aws --endpoint-url --no-verify-ssl s3 ls s3://bucket1